New link in the top of page "IRC Chat".
Register | Login
Views: 91865645
Main | Memberlist | Active users | Calendar | Last Posts | IRC Chat | Online users
Ranks | FAQ | XPW | Stats | Color Chart | Photo album
12-03-20 02:59 AM
0 users currently in General Chat.
Xeogaming Forums - General Chat - Bug Reports | |
Next newer thread | Next older thread
User Post
Kard Ayals
The Ultimate
Lv105
Posts2904
Counter2
Mv7Jm26
Hp2189/2189
Sp709/709
Atk361 Int279
Def389 Spd281
Hit254 Res275
Exp11969929
Next292331
Banhammer
Shining Armor
Admin Shield
Judge Hat
Admin Shoes
POWAR

Posted on 11-23-19 07:03 AM Link | Quote
Since the upgrade to PHP7, there's bound to be a few bugs here and there.

Please use this thread to report them (of course, they don't have to be related to PHP7).

Thanks.
Xeoman

Ball and Chain Trooper
Administrator








Since: 08-14-04
From: 255

Since last post: 7 hours
Last activity: 7 hours
Posted on 11-23-19 09:23 PM Link | Quote
Smilies don't seem to be registering.

Nothing else so far!


(Last edited by Xeoman on 11-23-19 09:51 PM)
Kard Ayals
The Ultimate
Lv105
Posts2904
Counter2
Mv7Jm26
Hp2189/2189
Sp709/709
Atk361 Int279
Def389 Spd281
Hit254 Res275
Exp11969929
Next292331
Banhammer
Shining Armor
Admin Shield
Judge Hat
Admin Shoes
POWAR

Posted on 11-24-19 08:02 AM Link | Quote
And that's one thing fixed. Forgot I changed the smilies data file locally, but I only uploaded the modified PHP files when deploying.
Jamie









Since: 03-27-20

Since last post: 66 days
Last activity: 66 days
Posted on 03-27-20 11:33 PM Link | Quote
The thread title is spelt wrong. It’s “bug reports”

- Some MySQL duplicate primary key notice when registering.
- Showing users’ posts doesn’t work. (Complete white screen)
- RPG stats also don’t work (still).
- The default theme loads mixed content on index.php at least, breaking HTTPS there.

On a note, maybe it would be worth making one of the domains non-HTTPS (and one full-HTTPS) for accessibility - I wouldn’t mind accessing this place from stupidly old VMs or something for instance lol. The HTTPS one should stay indexed in Google, for reference.
Jamie









Since: 03-27-20

Since last post: 66 days
Last activity: 66 days
Posted on 09-16-20 07:02 PM Link | Quote


Glaring bug when you attempt a new thread in a restricted forum: the actual forum's title is exposed there, which could have been worse had I been able to post in the forum, heh. Adding a power level / login check in whatever handles this (not sure what it is in AB1) will fix the problem.

According to the F12 console, there are also some bugs related to mixed content that have yet to be fixed (tested on a few pages): smiles seem to be hotlinked over HTTP for some reason, while there are two CSS styles in the Purple theme (from what I can tell, at least one of them is site-wide so it affects any theme)... probably an artifact of some configuration not being updated. They also all point to www'd and .net, so that could also have some explanation - they should all really be relative to what domain the user is visiting, therefore interception is less likely to happen as part of an MITM attack.

http://img.photobucket.com/albums/v372/DeadOrAlive/snapshot20070222193121.png and http://www.xeogaming.net/board/images/xeo/ctside.jpg are both loaded over HTTP on this theme's style sheet (neither even seem to load anymore either, as for the latter, even removing /board/ doesn't change this, so...) - I could test some of the others but I'm lazy, expecting similar results and also Purple is a brilliant theme so yeah



(Last edited by Jamie on 09-16-20 07:07 PM)
Next newer thread | Next older thread
Xeogaming Forums - General Chat - Bug Reports |



xeogaming.org

AcmlmBoard 1.92++ r4 Baseline
?2000-2013 Acmlm, Emuz, Blades, Xkeeper, DarkSlaya*, Lord Alexandor*
*Unofficial Updates
Page rendered in 0.194 seconds.
0.030